Status Page Outage
Incident Report for Mawersoft
Resolved
This incident has been resolved.
Posted Dec 18, 2020 - 11:29 UTC
Update
Basic status page functionality has now returned. We will continue to restore minor elements of the service over the next few hours.
Posted Dec 18, 2020 - 11:29 UTC
Identified
We are currently working to restore status page functionality. During this time, users may be unable to view service uptime.
Posted Dec 17, 2020 - 10:05 UTC