Multiple-service outage caused by adverse weather conditions
Incident Report for Mawersoft
Resolved
This incident has been resolved.
Posted Jul 12, 2021 - 21:13 UTC
Identified
Adverse weather conditions at a server provider location has caused an ongoing outage of several services. We are working on restoring them as soon as possible.
Posted Jul 12, 2021 - 18:35 UTC
This incident affected: Website (Signd).